境外服务器502,大家是如何搞定的

我在香港,买了一台服务器:IP:38.76.xxx.xxx

我部署了一些服务,例如:

CPA:http://38.76.xx.xx:8317
newapi:http://38.76.xx.xx:13300

国内直接访问,会报错502,有何解决方案吗?

我套一层自签hpps证书可以解决,但是毕竟是自签证书,有时候会弹框很麻烦,有些CLI也会报错

请问下各位佬,有何好办法吗?
我有两个想法,frpc打到国内转发?或者买个便宜的域名+证书

4 个赞

搞个域名,然后套cloudflare tunnel

佬,域名有推荐的吗,便宜点的,多买几年

6~8位数字xyz, 10年约50左右,供参考

不研究这个。。我自己买就是腾讯云随便买的,买个一年不续费,到时候再换一个就行
买完在控制台里面把解析的域名服务器改成cloudflare官方的就行

搞CF反代

那首先还是得搞域名,对吗,佬

佬,指个路

是的,你可以把域名托管到 Cloudflare 上,然后通过 Cloudflare的 Workers 编写代码,把请求反向代理到你的服务器上

好嘞,我去找找便宜的域名

直接用免费域名就行了呗

www.dnshe.com

1 个赞

免费域名https://my.dnshe.com/

免费证书https://trustcert.czdgg.top/

1 个赞

感谢指路