serv00部署二次元大佬和苦力怕大佬的免登录API(还差最后一步)

自己去fork到自己的仓库,自己去main.go更改端口为serv00允许的端口

安装go环境(serv00有go环境,但是版本不行)

wget https://go.dev/dl/go1.21.9.freebsd-amd64.tar.gz
tar -xzf go1.21.9.freebsd-amd64.tar.gz
rm go1.21.9.freebsd-amd64.tar.gz

go添加到PATH

步骤 1: 编辑你的 shell 配置文件
nano ~/.bashrc

在文件的末尾,添加以下行:
export PATH="$HOME/language/go/bin:$PATH"
按下 Ctrl + O 保存文件,然后回车,然后按 Ctrl + X 退出 nano。

步骤 3: 应用更改
重新加载 .bashrc 文件:
source ~/.bashrc

步骤 4: 验证更改
go version

之后

git clone https://github.com/aurora-develop/aurora.git
cd aurora
go mod tidy
go build -o aurora .
./aurora
curl --location 'http://127.0.0.1:4545/v1/chat/completions' --header 'Content-Type: application/json' --data '{"model": "gpt-3.5-turbo", "messages": [{"role": "user", "content": "Say this is a test!"}]}'

不知道为什么报错,等待大佬给出解决方法

[neobox@s2]:<~>$ curl --location 'http://127.0.0.1:4545/v1/chat/completions' --header 'Content-Type: application/json' --data '{"model": "gpt-3.5-turbo", "messages": [{"role": "user", "content": "Say this is a test!"}]}'
{"error":{"code":"error","message":"Unauthorized","param":null,"type":"401 Unauthorized"}}[neobox@s2]:<~>$ 
[neobox@s2]:<~/test/aurora>$ ./aurora
Error: please put HAR files in harPool directory!
[GIN-debug] [WARNING] Creating an Engine instance with the Logger and Recovery middleware already attached.

[GIN-debug] [WARNING] Running in "debug" mode. Switch to "release" mode in production.
 - using env:   export GIN_MODE=release
 - using code:  gin.SetMode(gin.ReleaseMode)

[GIN-debug] GET    /ping                     --> main.main.func1 (4 handlers)
[GIN-debug] OPTIONS /v1/chat/completions      --> main.optionsHandler (4 handlers)
[GIN-debug] POST   /v1/chat/completions      --> main.nightmare (4 handlers)
2024/04/03 18:52:00 84288 0.0.0.0:4545
8 Likes

深夜为你点赞

1 Like

API 报 401 了可还行,Authorization 附了吗

1 Like

加油 天亮前搞定:+1:

二次元大佬的不需要令牌,但是不知道为什么报错,因为我在本地电脑运行了,直接docker,没有一点报错,也不需要令牌

1 Like

都是大神 就像看天书

可能是系统兼容问题?你试试用纯 FreeBSD 部署一遍

常规话题快问快答

好像是ip不允许使用免登

这里的不登录是不是需要把你自己的token放进去啊。

不用,一把梭,然后直接就可以调用了

最新版不行了,启动报错 fileCache.IsExist err: stat /tmp/fake_useragent_0.2.0.json: permission denied

1 Like

明天开个哭试一下serv00

1 Like

好家伙,才发现是作者大佬,大佬辛苦了

首先你关注错了方向。你可以先使用 Serv00 搭一个代理,试一下 Serv00 的 IP 地址到底能不能免登录使用 ChatGPT 。

当然我可以提前告诉你,是不可以的,要美国的 IP 地址。

另外你修改代码再go build的步骤是多余的,在运行时可以使用环境变量更改端口:

export SERVER_PORT=xxxx

然后,如果你希望白嫖部署免登录 API ,你可以看我的 Blog :使用免费美国IP部署FreeGPT35

2 Likes

这是因为源仓库使用了这个依赖库:

解决办法是使用环境变量替换临时文件的存储路径:

export TMPDIR=$PWD
2 Likes

ok,大佬,我现在去看,我去看了一下大佬的博客,原来哪些serv00教程都是你写的,膜拜 :heart_eyes: :heart_eyes:

想到了但是不知道怎么解决,谢谢大佬

佬,所以serv00支持免登陆吗

你搭个桥没有问题的 我记得论坛有人讨论过